Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unexpected behaviour UR10e using reference frames
#1
Hi, would appreciate any insights/experiences with this issue.

When I create a program for a UR10e and download using the URP post-processor, I can run my programs as expected as long as the "set reference frame" in RoboDK is the UR10e Base. I'd like to plan my targets with respect to a different reference frame (say, Frame 1), but I can't see anything in the URP post-processor output that identifies this change in base. Consequently, the robot does not move as simulated if I select a different reference frame.

I've tried defining a base feature on the UR10 (physically moving the robot) and then copying those numbers into RoboDK to align my real and virtual environments, but I still get a path which is completely unreachable when I transfer the program from RoboDK to the actual robot using this new reference frame.

Any tips/tricks to help solve this would be greatly appreciated!
#2
When you use the URP post processor, the targets are automatically exported with respect to the robot base.

Also, note that we recently improved the UR post processor to fix a related issue. I recommend you to update RoboDK to the latest version.
#3
Hi Albert,

Many thanks for your reply. I've downloaded the newest UR post processor, but the targets are still exported with respect to the robot base. Are there any plans to assign the targets relative to a base chosen by the user? I've also noted that targets seem to be exported with the full joint angles - is this needed by the UR system? Being familiar with KUKA robots, I am used to seeing just the Cartesian values for each target and the robot then using the joint configuration from any starting point to reach the intended pose.

What would your suggested workflow be for a more flexible/fixtureless setup using RoboDK and a UR cobot? If all targets are exported with respect to the robot base, how would the user update a path if the object/workpiece moves from the position it was in when the simulation was done?
#4
Hi NDE, 

Can you make sure that you are using this attached post-processor?

.py   Universal_Robots_URP.py (Size: 44.94 KB / Downloads: 223)

Jeremy
#5
Hi,

I am having the same issue. I have verified that I am using the above post-processor. What else can I look at?

Thank You,
Gus
#6
Hi GusB,

Did you replace the post-processor you had in "C:/RoboDK/Posts" by the one I attached to my previous answer?
The name will be the same, but I corrected a small mistake on our end with the one I posted.

Jeremy
#7
Hi!

Is there any way to export reference frames from RDK to a UR10e inside a .URP (using the Universal Robots URP postprocessor)? I would like to use data from the local reference frame defined in RoboDK to modify it/correct it according to the real world positions and dimensions. Basically, I would like a variable with its data so I can move it arround to position targets relative to the local reference frame. The waypoints that are recalculated with respect to the robot's base, don't do well with our situation since we have multiple workzones around the robot and physical dimenions do not match up with the offline simulation. It would be a major hassle to shift every target point (there are more than a hundred).


All the best!
#8
The standard UR post-processor supports reference frames (script).
Can't you use this one?

Otherwise, it would require some improvement to the URP post-processor.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#9
I've looked into the .script equivallent of the .URP program and there is a line where it says set_reference(p["six values"]), however it is commented out with a #. I couldn't find any official documentation with said script command. I'm using the URP Postprocessor. Do I specifically need to use the standard post processor to get to use the reference frame?

It would be really helpful if a reference frame variable was present in .URP files also. It would benefit the deployment time and ease of use not only in UR both also other robots.

Thanks
#10
Hi again,

Inline with the question I've posted earlier. To my understanding, if you export with the URP post processor, targets that are nested inside a reference frame, get recalculated with respect to the robot base.

I've looked intside settings of RoboDk and I've found an option(Options->Drivers->Robot Drivers-> Last checkbox): there is a check box that says "Provide Cartesian coordinates with respect to the reference (instead of the robot base)". Could you elaborate a bit on what this means? It is kinda self explanatory, but I want to make sure 100% beforehand. Could this solve my issue when exporting reference frames?


Cheers


Cheers
  




Users browsing this thread:
1 Guest(s)