Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unexpected behaviour UR10e using reference frames
Hi, would appreciate any insights/experiences with this issue.

When I create a program for a UR10e and download using the URP post-processor, I can run my programs as expected as long as the "set reference frame" in RoboDK is the UR10e Base. I'd like to plan my targets with respect to a different reference frame (say, Frame 1), but I can't see anything in the URP post-processor output that identifies this change in base. Consequently, the robot does not move as simulated if I select a different reference frame.

I've tried defining a base feature on the UR10 (physically moving the robot) and then copying those numbers into RoboDK to align my real and virtual environments, but I still get a path which is completely unreachable when I transfer the program from RoboDK to the actual robot using this new reference frame.

Any tips/tricks to help solve this would be greatly appreciated!
When you use the URP post processor, the targets are automatically exported with respect to the robot base.

Also, note that we recently improved the UR post processor to fix a related issue. I recommend you to update RoboDK to the latest version.
Hi Albert,

Many thanks for your reply. I've downloaded the newest UR post processor, but the targets are still exported with respect to the robot base. Are there any plans to assign the targets relative to a base chosen by the user? I've also noted that targets seem to be exported with the full joint angles - is this needed by the UR system? Being familiar with KUKA robots, I am used to seeing just the Cartesian values for each target and the robot then using the joint configuration from any starting point to reach the intended pose.

What would your suggested workflow be for a more flexible/fixtureless setup using RoboDK and a UR cobot? If all targets are exported with respect to the robot base, how would the user update a path if the object/workpiece moves from the position it was in when the simulation was done?
Hi NDE, 

Can you make sure that you are using this attached post-processor?

.py (Size: 44.94 KB / Downloads: 170)


I am having the same issue. I have verified that I am using the above post-processor. What else can I look at?

Thank You,
Hi GusB,

Did you replace the post-processor you had in "C:/RoboDK/Posts" by the one I attached to my previous answer?
The name will be the same, but I corrected a small mistake on our end with the one I posted.


Users browsing this thread:
1 Guest(s)