Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Yaskawa GP25-12. First rotation is off by 180 degree

#1
Robot looks ok and simulation works well.
However: First rotation is just wrong in the model, where can I adjust this?    
#2
Are you referring to the turntable which is off by 180 deg?

If so, you need to adjust the theta 2 angle in the Turntable parameters section by 180 deg. If you can provide us with the RDK file we can better help you.
#3
here is the rdk file, thanks


Attached Files
.rdk   Yaskawa 1.rdk (Size: 3.74 MB / Downloads: 23)
#4
What do you mean by the first rotation is wrong? Are you referring to the turntable?
#5
   
No Not the turntable at all.
I am pretty new to this so let me try again.
Original post was fixed by looking at the welding torch setup in the robot. Z axis is pointing toward the robot instead of all the examples where the Z axis is pointing from the gun.

But the question is somewhat valid again. first rotation is flipped 180 degrees from the animation. This makes it very hard to actually know what the robot does before running the program.

In the photo one can see the first rotation in target two and it is 180 degree from the simulation.
Also added the new RDK file with correct orientation of the torch and the target and program2.

Program1 is imported from the robot where I used the teach pendant and both simulation and robot behaves the same. I know I turned the wrist heavily on program2 but I have to force the first rotation this way to keep it inside the pulse limits.


Attached Files
.rdk   Yaskawa 1.rdk (Size: 3.74 MB / Downloads: 18)
#6
JBI programs usually refer to the active tool and coordinate systems by ID. You can customize this behavior with your post processor.

Using the default settings, the robot will use the tool id 0 if the tool name is Tool 0, and the frame 3 if your coordinate system is Frame 3.

I forget if you can set Tool index 0 with Yaskawa Motoman but I recommend you to keep this tool at the robot flange (as if you didn't have any tools), and set Tool index 1 as the torch and enter the TCP coordinates (they should both be the same in RoboDK and the robot controller).
#7
I added the user coordinate system on id 3 to fit the square. This works
Tool 0 is the "standard tool" in the machine. This works.
Added photo of the tool setup in the motoman.

 If you look at the latest rdk file with target2 and the photoin the previous comment from me, you can see the elbow in about 180 degrees turned in the wrong direction.

I can weld and use the robot from the teach pendant. 
I can't control is reliably from robodk, where the elbow rotation is about 180 degree turned to the opposite side which is my problem.


Attached Files Thumbnail(s)
   
#8
OK to prevent the issue you described you should first move the robot to a joint target using a MoveJ command.

You can convert a Cartesian target (shown as a red target in the RoboDK tree) into a Joint target (shown as green in the RoboDK tree) by right clicking on your target and checking the option Joint Target.
#9
That gives a program that looks like this:
Code:
/JOB
//NAME PROG4
//POS
///NPOS 2,0,0,0,0,0
///TOOL 0
///POSTYPE PULSE
///PULSE
C00000=0,0,0,0,0,0
C00001=0,0,0,0,0,0
//INST
///DATE 2024/02/18 15:53
///ATTR SC,RW
///GROUP1 RB1
NOP
'Program generated by RoboDK v
'5.6.8 for Yaskawa GP25-12 on
'18/02/2024 15:53:57
'Using nominal kinematics.
'Using USER 3:
'1100.000,-500.000,-520.000,0.
'00,0.00,0.00
'Using TOOL 0:
'-86.000,0.000,451.500,180.00,
'-36.00,0.00
MOVJ C00000 VJ=100.0
MOVL C00001 V=150.0
END
With C positions doing nothing.
#10
You should properly update the pulses/degree ratio for Yaskawa/Motoman robots.

You can do it by following the steps in this section of the documentation:
https://robodk.com/doc/en/Robots-Motoman...omanPulses
  




Users browsing this thread:
4 Guest(s)