Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

shape add-in on ubuntu 20.04

There is an error like on attachment screen shot . What is the easiest way to handle this error?
You may need to install PySide for Python manually on Ubuntu:
pip install PySide
I tried to install requirement from add-in manager.
First I got error related with pip than I install python3-pip with apt-get.
Later install requirement was completed without error but.
Requirement.txt says PySide2==5.15.* I also tried to changed it to 5.12 but I have still same error.
There is list of available lib on system like below.

grass@grass-XPS-15-9570:~/catkin_ws$ ls -al /lib/x86_64-linux-gnu/*
lrwxrwxrwx 1 root root      20 Jan  5  2022 /lib/x86_64-linux-gnu/ ->
lrwxrwxrwx 1 root root      20 Jan  5  2022 /lib/x86_64-linux-gnu/ ->
lrwxrwxrwx 1 root root      20 Jan  5  2022 /lib/x86_64-linux-gnu/ ->
-rw-r--r-- 1 root root 5519624 Jan  5  2022 /lib/x86_64-linux-gnu/
The errors are due to the fact that RoboDK for Linux is built against Qt 5.12, while RoboDK for Windows is built with 5.15. As Windows is our main platform, we are using PySide2 5.15 for requirements. However, PySide2 on Linux (5.15) resolves its dependencies using the RoboDK dependencies (5.12).

You can try to replace your PySide2 version to 5.12 (in the requirements.txt of the Shape Add-in, and with the console). Ensure you are editing the same interpreter as RoboDK uses (Tools-Options-Python):
pip install --upgrade PySide2 5.12.*
Please read the Forum Guidelines before posting!
Find useful information about RoboDK by visiting our Online Documentation.
Thanks for your reply.

After editing requirement, I got below message.


I understand that, RoboDK can run with full functionality in Linux LTS if we have lucky.
For full support better to use windows version.

Users browsing this thread:
1 Guest(s)