Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

trouble connecting UR10 robot to robodk


I've been having trouble connecting a UR10 robot to roboDK

The robot is connected directly via a Network cable, and I am able to ping the robot, however when I get to actually connecting it will get stuck at waiting.

Ive seen other threads with users having this issue however none have contained a solution that worked for me.

I have disabled the firewall and tried changing the versions in apiur but it did not solve the issue
Do you see any errors in the log window of your robot?

Can you share a print screen of the connection log of RoboDK?
The log on the controller doesn't show anything at all when I try to connect. I have attached a screenshot of the robodk log and a couple others that may be useful. I am connecting through a direct cable connection to the control box.

Attached Files Thumbnail(s)
If I run UR_Monitoring_CSV it will retrieve and display the real robot position in robodk but it will not continuously update it if I move the robot afterwards, I have added a switch between the laptop and the robot as per suggestion in another thread about a similar issue but it did not resolve the problem.
(05-24-2022, 07:12 AM)Marcin Wrote:
(09-02-2019, 10:06 PM)Albert Wrote: Let's try to set up the UR driver manually:
  1. Take the file attached and update the IP and port in the first 2 lines (IP of the robot and the communication port you specify in RoboDK).
  2. You can load the attached file on the robot and run it (you'll need to setup a new program to run a script file as shown here).
  3. You may see errors in the log (let me know if this is the case).
If you don't see any errors it means something is blocking the connection (firewall, antivirus or Windows user account control doesn't let you setup a server connection).

I tried to run this program but this error popped up.

Albert, maybe you have any other ideas?

I am also getting the same error: NameError: name: 'get_standard_digital_out' is not defined, when I try to setup the driver manually
OK great, it looks like new controller updates removed support for get_standard_digital_out. We are updating RoboDK with a new version of the driver for UR which will not use this function (the search function will be disabled in this case).

We'll be pushing a new driver update this week to support your controller (on Sunday the latest). Make sure that your controller version is set to 1 instead of the 3 (default is 3). This setting is saved with the INI file.
Thanks for the help, I can now connect the robot to robodk. I have encountered another issue though, I can get the robot to run programs with both MoveJ and MoveC instructions however when I try to use a MoveL instruction the robot will give me an error: "Unexpected instruction restarting communications"

Attached Files Thumbnail(s)

Users browsing this thread:
1 Guest(s)