Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can I use Raspberry Pi IP addresss in RoboDK on Windows
#1
I Have installed robodk software on windows and I have raspberry pi 3+ B model  which is connected with 6 of robotic arms? 
 There is the option of connecting. Can i use my raspberry pi IP over there and can i run/ control  the robot?
#2
(04-12-2022, 04:50 PM)omkar11023 Wrote: I Have installed robodk software on windows and I have raspberry pi 3+ B model  which is connected with 6 of robotic arms? 
 There is the option of connecting. Can i use my raspberry pi IP over there and can i run/ control  the robot?

The easier way would be to install RoboDK on your Raspberry Pi and control the robot(through RoboDK) using the RoboDK API on your windows computer. Otherwise you would have to do some network routing which is not really part of RoboDK but your network setup.

https://robodk.com/blog/robodk-for-raspberry-pi/
#3
Hi as per your guidance I have downloaded RoboDK in Raspberry Pi. After unzipping it I saw a text file regarding installation. I went step by step, but after executing the last command (i.e. ./RoboDK-Start.sh) I'm getting this error:
Code:
sudo ./RoboDK-Start.sh
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
No running instances of RoboDK detected
Starting  RoboDK  v 5.3.0 . 20046  ...
OS:  PI64
Date build:  Mar  6 2021
Main process ID:  4983
Thread ID:  0x76fdf040
qt.qpa.xcb: QXcbConnection: XCB error: 148 (Unknown), sequence: 191, resource id: 0, major code: 140 (Unknown), minor code: 20
Loading settings...
Failed to acces global parameters file
Setting up default settings...
Default settings set
Failed to acces global parameters file
Setting up default settings...
Default settings set
Settings loaded
Statusbar:  "Language set to English"
Updating recent files menu...
Created language menu

What should I do now?
#4
I see you are trying to launch RoboDK 5.3. The latest version is 5.4. Did you download RoboDK from https://robodk.com/download?

There might also have been an issue when installing the dependencies, did you notice any errors when installing them? You can try reinstalling as a superuser (sudo sh)
#5
I have downloaded the recent version of robodk in raspberry pi 3 B+.
after that i have use this command " sudo ./Install-RoboDK.sh " .

Code:
Installing RoboDK in the following path:
/root/RoboDK

Press any key to continue

Directory Exists, overwrite? y/n y
Please wait... RoboDK will start when the installation is complete.

Deleting previous install
rmdir: failed to remove '/root/RoboDK': No such file or directory
Creating directory: /root/RoboDK
Changing permissions...
Copying files. Please wait...
Setting execute attributes to RoboDK folder
Installing gedit (RoboDK's default text editor for Linux)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
docbook-xml fonts-dejavu fonts-dejavu-extra gedit-common gir1.2-gtksource-4
gir1.2-peas-1.0 libamtk-5-0 libamtk-5-common libgspell-1-2
libgspell-1-common libgtksourceview-4-0 libgtksourceview-4-common
libpeas-1.0-0 libpeas-common libpython3.8 libpython3.8-minimal
libpython3.8-stdlib libtepl-5-0 libyelp0 sgml-data yelp yelp-xsl
Suggested packages:
docbook docbook-dsssl docbook-xsl docbook-defguide gedit-plugins perlsgml
w3-recs opensp libxml2-utils
The following NEW packages will be installed:
docbook-xml fonts-dejavu fonts-dejavu-extra gedit gedit-common
gir1.2-gtksource-4 gir1.2-peas-1.0 libamtk-5-0 libamtk-5-common
libgspell-1-2 libgspell-1-common libgtksourceview-4-0
libgtksourceview-4-common libpeas-1.0-0 libpeas-common libpython3.8
libpython3.8-minimal libpython3.8-stdlib libtepl-5-0 libyelp0 sgml-data yelp
yelp-xsl
0 upgraded, 23 newly installed, 0 to remove and 3 not upgraded.
Need to get 9,794 kB/10.5 MB of archives.
After this operation, 54.3 MB of additional disk space will be used.
Get:1 http://mirror.ossplanet.net/raspbian/raspbian bullseye/main armhf fonts-dejavu-extra all 2.37-2 [2,070 kB]
Get:2 http://mirror.pit.teraswitch.com/raspbian/raspbian bullseye/main armhf gedit-common all 3.38.1-1 [1,603 kB]
Get:3 http://mirror.as43289.net/raspbian/raspbian bullseye/main armhf libgtksourceview-4-common all 4.8.0-1 [553 kB]
Get:4 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian bullseye/main armhf libpython3.8-minimal armhf 3.8.7-1 [753 kB]
Get:6 http://mirror.ossplanet.net/raspbian/raspbian bullseye/main armhf libpython3.8 armhf 3.8.7-1 [1,344 kB]
Get:5 http://ftp.acc.umu.se/mirror/raspbian/raspbian bullseye/main armhf libpython3.8-stdlib armhf 3.8.7-1 [1,647 kB]
Get:8 http://mirror.pit.teraswitch.com/raspbian/raspbian bullseye/main armhf libamtk-5-common all 5.2.0-1 [7,492 B]
Get:13 http://mirror.as43289.net/raspbian/raspbian bullseye/main armhf yelp armhf 3.38.3-1 [778 kB]
Get:12 http://mirror.de.leaseweb.net/raspbian/raspbian bullseye/main armhf yelp-xsl all 3.38.3-1 [445 kB]
Get:7 http://mirror.ossplanet.net/raspbian/raspbian bullseye/main armhf gir1.2-peas-1.0 armhf 1.28.0-2 [12.4 kB]
Get:9 http://mirror.ossplanet.net/raspbian/raspbian bullseye/main armhf libtepl-5-0 armhf 5.0.1-2 [83.4 kB]
Get:10 http://mirror.ossplanet.net/raspbian/raspbian bullseye/main armhf gedit armhf 3.38.1-1 [343 kB]
Get:11 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian bullseye/main armhf libyelp0 armhf 3.38.3-1 [155 kB]
Fetched 6,905 kB in 8s (875 kB/s)                                              
Selecting previously unselected package sgml-data.
(Reading database ... 102374 files and directories currently installed.)
Preparing to unpack .../00-sgml-data_2.0.11+nmu1_all.deb ...
Unpacking sgml-data (2.0.11+nmu1) ...
Selecting previously unselected package docbook-xml.
Preparing to unpack .../01-docbook-xml_4.5-9_all.deb ...
Unpacking docbook-xml (4.5-9) ...
Selecting previously unselected package fonts-dejavu-extra.
Preparing to unpack .../02-fonts-dejavu-extra_2.37-2_all.deb ...
Unpacking fonts-dejavu-extra (2.37-2) ...
Selecting previously unselected package fonts-dejavu.
Preparing to unpack .../03-fonts-dejavu_2.37-2_all.deb ...
Unpacking fonts-dejavu (2.37-2) ...
Selecting previously unselected package gedit-common.
Preparing to unpack .../04-gedit-common_3.38.1-1_all.deb ...
Unpacking gedit-common (3.38.1-1) ...
Selecting previously unselected package libgtksourceview-4-common.
Preparing to unpack .../05-libgtksourceview-4-common_4.8.0-1_all.deb ...
Unpacking libgtksourceview-4-common (4.8.0-1) ...
Selecting previously unselected package libgtksourceview-4-0:armhf.
Preparing to unpack .../06-libgtksourceview-4-0_4.8.0-1_armhf.deb ...
Unpacking libgtksourceview-4-0:armhf (4.8.0-1) ...
Selecting previously unselected package gir1.2-gtksource-4:armhf.
Preparing to unpack .../07-gir1.2-gtksource-4_4.8.0-1_armhf.deb ...
Unpacking gir1.2-gtksource-4:armhf (4.8.0-1) ...
Selecting previously unselected package libpeas-common.
Preparing to unpack .../08-libpeas-common_1.28.0-2_all.deb ...
Unpacking libpeas-common (1.28.0-2) ...
Selecting previously unselected package libpython3.8-minimal:armhf.
Preparing to unpack .../09-libpython3.8-minimal_3.8.7-1_armhf.deb ...
Unpacking libpython3.8-minimal:armhf (3.8.7-1) ...
Selecting previously unselected package libpython3.8-stdlib:armhf.
Preparing to unpack .../10-libpython3.8-stdlib_3.8.7-1_armhf.deb ...
Unpacking libpython3.8-stdlib:armhf (3.8.7-1) ...
Selecting previously unselected package libpython3.8:armhf.
Preparing to unpack .../11-libpython3.8_3.8.7-1_armhf.deb ...
Unpacking libpython3.8:armhf (3.8.7-1) ...
Selecting previously unselected package libpeas-1.0-0:armhf.
Preparing to unpack .../12-libpeas-1.0-0_1.28.0-2_armhf.deb ...
Unpacking libpeas-1.0-0:armhf (1.28.0-2) ...
Selecting previously unselected package gir1.2-peas-1.0:armhf.
Preparing to unpack .../13-gir1.2-peas-1.0_1.28.0-2_armhf.deb ...
Unpacking gir1.2-peas-1.0:armhf (1.28.0-2) ...
Selecting previously unselected package libamtk-5-common.
Preparing to unpack .../14-libamtk-5-common_5.2.0-1_all.deb ...
Unpacking libamtk-5-common (5.2.0-1) ...
Selecting previously unselected package libamtk-5-0:armhf.
Preparing to unpack .../15-libamtk-5-0_5.2.0-1_armhf.deb ...
Unpacking libamtk-5-0:armhf (5.2.0-1) ...
Selecting previously unselected package libgspell-1-common.
Preparing to unpack .../16-libgspell-1-common_1.8.4-1_all.deb ...
Unpacking libgspell-1-common (1.8.4-1) ...
Selecting previously unselected package libgspell-1-2:armhf.
Preparing to unpack .../17-libgspell-1-2_1.8.4-1_armhf.deb ...
Unpacking libgspell-1-2:armhf (1.8.4-1) ...
Selecting previously unselected package libtepl-5-0:armhf.
Preparing to unpack .../18-libtepl-5-0_5.0.1-2_armhf.deb ...
Unpacking libtepl-5-0:armhf (5.0.1-2) ...
Selecting previously unselected package gedit.
Preparing to unpack .../19-gedit_3.38.1-1_armhf.deb ...
Unpacking gedit (3.38.1-1) ...
Selecting previously unselected package libyelp0:armhf.
Preparing to unpack .../20-libyelp0_3.38.3-1_armhf.deb ...
Unpacking libyelp0:armhf (3.38.3-1) ...
Selecting previously unselected package yelp-xsl.
Preparing to unpack .../21-yelp-xsl_3.38.3-1_all.deb ...
Unpacking yelp-xsl (3.38.3-1) ...
Selecting previously unselected package yelp.
Preparing to unpack .../22-yelp_3.38.3-1_armhf.deb ...
Unpacking yelp (3.38.3-1) ...
Setting up gedit-common (3.38.1-1) ...
Setting up libpython3.8-minimal:armhf (3.8.7-1) ...
Setting up libgspell-1-common (1.8.4-1) ...
Setting up libyelp0:armhf (3.38.3-1) ...
Setting up libpeas-common (1.28.0-2) ...
Setting up fonts-dejavu-extra (2.37-2) ...
Setting up sgml-data (2.0.11+nmu1) ...
Setting up libpython3.8-stdlib:armhf (3.8.7-1) ...
Setting up libamtk-5-common (5.2.0-1) ...
Setting up libgtksourceview-4-common (4.8.0-1) ...
Setting up libgspell-1-2:armhf (1.8.4-1) ...
Setting up yelp-xsl (3.38.3-1) ...
Setting up fonts-dejavu (2.37-2) ...
Setting up yelp (3.38.3-1) ...
Setting up libamtk-5-0:armhf (5.2.0-1) ...
Setting up libgtksourceview-4-0:armhf (4.8.0-1) ...
Setting up libpython3.8:armhf (3.8.7-1) ...
Setting up libtepl-5-0:armhf (5.0.1-2) ...
Setting up libpeas-1.0-0:armhf (1.28.0-2) ...
Setting up gir1.2-gtksource-4:armhf (4.8.0-1) ...
Setting up gir1.2-peas-1.0:armhf (1.28.0-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for sgml-base (1.30) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for fontconfig (2.13.1-4.2) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for libglib2.0-0:armhf (2.66.8-1) ...
Setting up docbook-xml (4.5-9) ...
Setting up gedit (3.38.1-1) ...
update-alternatives: using /usr/bin/gedit to provide /usr/bin/gnome-text-editor (gnome-text-editor) in auto mode
Processing triggers for sgml-base (1.30) ...
Installing Qt dependencies
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package qt5-default is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'qt5-default' has no installation candidate
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
libqt5websockets5
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/56.2 kB of archives.
After this operation, 213 kB of additional disk space will be used.
Selecting previously unselected package libqt5websockets5:armhf.
(Reading database ... 106005 files and directories currently installed.)
Preparing to unpack .../libqt5websockets5_5.15.2-2_armhf.deb ...
Unpacking libqt5websockets5:armhf (5.15.2-2) ...
Setting up libqt5websockets5:armhf (5.15.2-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
libegl-dev libgl-dev libgles-dev libglx-dev libpthread-stubs0-dev
libqt5opengl5 libqt5opengl5-dev libqt5test5 libvulkan-dev libx11-dev
libxau-dev libxcb1-dev libxdmcp-dev libxext-dev qt5-qmake qt5-qmake-bin
qtbase5-dev qtbase5-dev-tools qtchooser x11proto-dev x11proto-xext-dev
xorg-sgml-doctools xtrans-dev
Suggested packages:
libx11-doc libxcb-doc libxext-doc default-libmysqlclient-dev firebird-dev
libpq-dev libsqlite3-dev unixodbc-dev
The following NEW packages will be installed:
libegl-dev libgl-dev libgles-dev libglx-dev libpthread-stubs0-dev
libqt5opengl5 libqt5opengl5-dev libqt5test5 libqt5websockets5-dev
libvulkan-dev libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxext-dev
qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools qtchooser x11proto-dev
x11proto-xext-dev xorg-sgml-doctools xtrans-dev
0 upgraded, 24 newly installed, 0 to remove and 3 not upgraded.
Need to get 679 kB/5,854 kB of archives.
After this operation, 41.6 MB of additional disk space will be used.
Get:3 http://mirror.nl.leaseweb.net/raspbian/raspbian bullseye/main armhf libxau-dev armhf 1:1.0.9-1 [22.3 kB]
Get:2 http://mirrors.gigenet.com/raspbian/raspbian bullseye/main armhf x11proto-dev all 2020.1-1 [594 kB]
Get:1 http://ftp.acc.umu.se/mirror/raspbian/raspbian bullseye/main armhf xorg-sgml-doctools all 1:1.11-1.1 [22.1 kB]
Get:4 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian bullseye/main armhf libxdmcp-dev armhf 1:1.1.2-3 [40.9 kB]
Fetched 679 kB in 4s (162 kB/s)        
Selecting previously unselected package xorg-sgml-doctools.
(Reading database ... 106011 files and directories currently installed.)
Preparing to unpack .../00-xorg-sgml-doctools_1%3a1.11-1.1_all.deb ...
Unpacking xorg-sgml-doctools (1:1.11-1.1) ...
Selecting previously unselected package x11proto-dev.
Preparing to unpack .../01-x11proto-dev_2020.1-1_all.deb ...
Unpacking x11proto-dev (2020.1-1) ...
Selecting previously unselected package libxau-dev:armhf.
Preparing to unpack .../02-libxau-dev_1%3a1.0.9-1_armhf.deb ...
Unpacking libxau-dev:armhf (1:1.0.9-1) ...
Selecting previously unselected package libxdmcp-dev:armhf.
Preparing to unpack .../03-libxdmcp-dev_1%3a1.1.2-3_armhf.deb ...
Unpacking libxdmcp-dev:armhf (1:1.1.2-3) ...
Selecting previously unselected package xtrans-dev.
Preparing to unpack .../04-xtrans-dev_1.4.0-1_all.deb ...
Unpacking xtrans-dev (1.4.0-1) ...
Selecting previously unselected package libpthread-stubs0-dev:armhf.
Preparing to unpack .../05-libpthread-stubs0-dev_0.4-1_armhf.deb ...
Unpacking libpthread-stubs0-dev:armhf (0.4-1) ...
Selecting previously unselected package libxcb1-dev:armhf.
Preparing to unpack .../06-libxcb1-dev_1.14-3_armhf.deb ...
Unpacking libxcb1-dev:armhf (1.14-3) ...
Selecting previously unselected package libx11-dev:armhf.
Preparing to unpack .../07-libx11-dev_2%3a1.7.2-1_armhf.deb ...
Unpacking libx11-dev:armhf (2:1.7.2-1) ...
Selecting previously unselected package libglx-dev:armhf.
Preparing to unpack .../08-libglx-dev_1.3.2-1_armhf.deb ...
Unpacking libglx-dev:armhf (1.3.2-1) ...
Selecting previously unselected package libgl-dev:armhf.
Preparing to unpack .../09-libgl-dev_1.3.2-1_armhf.deb ...
Unpacking libgl-dev:armhf (1.3.2-1) ...
Selecting previously unselected package libegl-dev:armhf.
Preparing to unpack .../10-libegl-dev_1.3.2-1_armhf.deb ...
Unpacking libegl-dev:armhf (1.3.2-1) ...
Selecting previously unselected package libgles-dev:armhf.
Preparing to unpack .../11-libgles-dev_1.3.2-1_armhf.deb ...
Unpacking libgles-dev:armhf (1.3.2-1) ...
Selecting previously unselected package libqt5opengl5:armhf.
Preparing to unpack .../12-libqt5opengl5_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking libqt5opengl5:armhf (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package libqt5test5:armhf.
Preparing to unpack .../13-libqt5test5_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking libqt5test5:armhf (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package libvulkan-dev:armhf.
Preparing to unpack .../14-libvulkan-dev_1.2.162.0-1_armhf.deb ...
Unpacking libvulkan-dev:armhf (1.2.162.0-1) ...
Selecting previously unselected package x11proto-xext-dev.
Preparing to unpack .../15-x11proto-xext-dev_2020.1-1_all.deb ...
Unpacking x11proto-xext-dev (2020.1-1) ...
Selecting previously unselected package libxext-dev:armhf.
Preparing to unpack .../16-libxext-dev_2%3a1.3.3-1.1_armhf.deb ...
Unpacking libxext-dev:armhf (2:1.3.3-1.1) ...
Selecting previously unselected package qt5-qmake-bin.
Preparing to unpack .../17-qt5-qmake-bin_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking qt5-qmake-bin (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package qtchooser.
Preparing to unpack .../18-qtchooser_66-2_armhf.deb ...
Unpacking qtchooser (66-2) ...
Selecting previously unselected package qt5-qmake:armhf.
Preparing to unpack .../19-qt5-qmake_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking qt5-qmake:armhf (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package qtbase5-dev-tools.
Preparing to unpack .../20-qtbase5-dev-tools_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking qtbase5-dev-tools (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package qtbase5-dev:armhf.
Preparing to unpack .../21-qtbase5-dev_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking qtbase5-dev:armhf (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package libqt5opengl5-dev:armhf.
Preparing to unpack .../22-libqt5opengl5-dev_5.15.2+dfsg-9+rpi1_armhf.deb ...
Unpacking libqt5opengl5-dev:armhf (5.15.2+dfsg-9+rpi1) ...
Selecting previously unselected package libqt5websockets5-dev:armhf.
Preparing to unpack .../23-libqt5websockets5-dev_5.15.2-2_armhf.deb ...
Unpacking libqt5websockets5-dev:armhf (5.15.2-2) ...
Setting up libvulkan-dev:armhf (1.2.162.0-1) ...
Setting up libpthread-stubs0-dev:armhf (0.4-1) ...
Setting up xtrans-dev (1.4.0-1) ...
Setting up qt5-qmake-bin (5.15.2+dfsg-9+rpi1) ...
Setting up libqt5opengl5:armhf (5.15.2+dfsg-9+rpi1) ...
Setting up xorg-sgml-doctools (1:1.11-1.1) ...
Setting up libqt5test5:armhf (5.15.2+dfsg-9+rpi1) ...
Setting up qtchooser (66-2) ...
Setting up qt5-qmake:armhf (5.15.2+dfsg-9+rpi1) ...
Setting up qtbase5-dev-tools (5.15.2+dfsg-9+rpi1) ...
Processing triggers for sgml-base (1.30) ...
Setting up x11proto-dev (2020.1-1) ...
Setting up libxau-dev:armhf (1:1.0.9-1) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Processing triggers for man-db (2.9.4-2) ...
Setting up libxdmcp-dev:armhf (1:1.1.2-3) ...
Setting up x11proto-xext-dev (2020.1-1) ...
Setting up libxcb1-dev:armhf (1.14-3) ...
Setting up libx11-dev:armhf (2:1.7.2-1) ...
Setting up libxext-dev:armhf (2:1.3.3-1.1) ...
Setting up libglx-dev:armhf (1.3.2-1) ...
Setting up libgl-dev:armhf (1.3.2-1) ...
Setting up libegl-dev:armhf (1.3.2-1) ...
Setting up libgles-dev:armhf (1.3.2-1) ...
Setting up qtbase5-dev:armhf (5.15.2+dfsg-9+rpi1) ...
Setting up libqt5websockets5-dev:armhf (5.15.2-2) ...
Setting up libqt5opengl5-dev:armhf (5.15.2+dfsg-9+rpi1) ...
Creating shortcuts...
rm: cannot remove '/root/Desktop/RoboDK.desktop': No such file or directory
./Create-Shortcut.sh: 6: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 7: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 8: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 9: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 10: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 11: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 12: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 13: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 14: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
rm: cannot remove '/root/RoboDK/RoboDK.desktop': No such file or directory
Installing RoboDK for Python 2 and Python 3...
Installing RoboDK for Python 2 and Python 3...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
python3 is already the newest version (3.9.2-3).
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
idle3 is already the newest version (3.9.2-3).
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
python3-pip is already the newest version (20.3.4-4+rpt1).
The following package was automatically installed and is no longer required:
libfuse2
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
Collecting robodk
Using cached robodk-5.4.0-py2.py3-none-any.whl (96 kB)
Using cached robodk-5.3.1-py2.py3-none-any.whl (83 kB)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
Collecting robodk
Using cached robodk-5.4.0-py2.py3-none-any.whl (96 kB)
Using cached robodk-5.3.1-py2.py3-none-any.whl (83 kB)
You can delete the RoboDK install folder now

Done!
Optionally start RoboDK behind the scenes by typing:
/root/RoboDK/RoboDK-Start-Hidden.sh

Optionally start RoboDK as a service on startup:
/root/RoboDK/Create-RoboDK-Service.sh

Start RoboDK by typing:
/root/RoboDK/RoboDK-Start.sh

pi@raspberrypi:~/Desktop/Install-RoboDK-Pi $ /root/RoboDK/RoboDK-Start.sh
bash: /root/RoboDK/RoboDK-Start.sh: Permission denied

Now what to do!!!!!!

As per you 2 advice the problem persists

Code:
pi@raspberrypi:~/Desktop/Install-RoboDK-Pi $ cd RoboDK-Pi
pi@raspberrypi:~/Desktop/Install-RoboDK-Pi/RoboDK-Pi $ sudo sh Install-RoboDK-Dependencies.sh
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package python3-pip
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
: not foundoDK-Dependencies.sh: 6:
Reading package lists... Done
E: You must put some 'deb-src' URIs in your sources.list
Reading package lists... Done
E: You must put some 'deb-src' URIs in your sources.list
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libinput-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libxcb-xinerama0
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libtspi-dev
: not foundoDK-Dependencies.sh: 14:

Is there any easy way to download robodk in Raspberry pi ( manually)
#6
as you can see in the terminal, there 14 dependencies of RoboDK that could not be installed and there was a prompt where you were denied permission (you should try using sudo)

Unfortunately, linux is not as user friendly as other operating systems and you should get used to Troubleshooting on these kind of systems. This is the standard way to install any program on linux.
You can start by making sure your repositories are up to date and trying to install the dependencies that were not found during installation.

If you do not have a fresh installation of Raspbian there might be some packages that are conflicting with these dependencies.
#7
A quick answer to your first question is that yes, you can connect to an instance of RoboDK remotely by starting the Robolink object on your client PC and providing the IP.

Example:
Code:
RDK = Robolink("raspberrypi")
# or any valid IP
RDK = Robolink("192.168.1.100")
Make sure RoboDK is running on the Raspberry Pi so you can connect from your Windows PC or any other remote client (you can start it manually or as a service).

RoboDK instances on linux/raspberry make the API available from external clients by default (this is not the case on Windows and you would need to make the API reachable from other computers in Tools-Options-Other). Make sure you are using a valid IP to connect.

In my opinion, the install worked. You can validate by starting RoboDK on the Raspberry Pi.
#8
Hello, 

I'm having exactly the same issue as omkar11023, while attempting to install RoboDK on the Raspberry Pi. 

It's installed 'successfully' in root and can be seen in there but at the same time it doesn't exist. Using sudo isn't helping either, unfortunately. 
I really think a thorough instructional video would benefit a great number of people and enable them to get use and enjoyment out of this version of RoboDK. It would be greatly appreciated.


Attached Files Thumbnail(s)
   
#9
Did you run the RoboDK install script while having a good internet connection?

Can you provide us with the console output of the installer script?
#10
Hello,

Yes. I had a good connection throughout. 

Thank you for your time.

Here is my install script output: 

Code:
pi@titus:~ $ sudo su
root@titus:/home/pi# cd Desktop/Install-RoboDK-Pi
root@titus:/home/pi/Desktop/Install-RoboDK-Pi# sudo ./Install-RoboDK.sh
Installing RoboDK in the following path:
/root/RoboDK

Press any key to continue

Please wait... RoboDK will start when the installation is complete.

Creating directory: /root/RoboDK
Changing permissions...
Copying files. Please wait...
Setting execute attributes to RoboDK folder
Installing gedit (RoboDK's default text editor for Linux)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
 docbook-xml fonts-dejavu fonts-dejavu-extra gedit-common gir1.2-gtksource-4
 gir1.2-peas-1.0 libamtk-5-0 libamtk-5-common libgspell-1-2
 libgspell-1-common libgtksourceview-4-0 libgtksourceview-4-common
 libpeas-1.0-0 libpeas-common libtepl-5-0 libyelp0 sgml-data yelp yelp-xsl
Suggested packages:
 docbook docbook-dsssl docbook-xsl docbook-defguide gedit-plugins perlsgml
 w3-recs opensp libxml2-utils
The following NEW packages will be installed:
 docbook-xml fonts-dejavu fonts-dejavu-extra gedit gedit-common
 gir1.2-gtksource-4 gir1.2-peas-1.0 libamtk-5-0 libamtk-5-common
 libgspell-1-2 libgspell-1-common libgtksourceview-4-0
 libgtksourceview-4-common libpeas-1.0-0 libpeas-common libtepl-5-0 libyelp0
 sgml-data yelp yelp-xsl
0 upgraded, 20 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,846 kB of archives.
After this operation, 37.8 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bullseye/main arm64 sgml-data all 2.0.11+nmu1 [179 kB]
Get:2 http://deb.debian.org/debian bullseye/main arm64 docbook-xml all 4.5-9 [84.4 kB]
Get:3 http://deb.debian.org/debian bullseye/main arm64 fonts-dejavu-extra all 2.37-2 [2,070 kB]
Get:4 http://deb.debian.org/debian bullseye/main arm64 fonts-dejavu all 2.37-2 [32.6 kB]
Get:5 http://deb.debian.org/debian bullseye/main arm64 gedit-common all 3.38.1-1 [1,603 kB]
Get:6 http://deb.debian.org/debian bullseye/main arm64 libgtksourceview-4-common all 4.8.0-1 [553 kB]
Get:7 http://deb.debian.org/debian bullseye/main arm64 libgtksourceview-4-0 arm64 4.8.0-1 [209 kB]
Get:8 http://deb.debian.org/debian bullseye/main arm64 gir1.2-gtksource-4 arm64 4.8.0-1 [28.0 kB]
Get:9 http://deb.debian.org/debian bullseye/main arm64 libpeas-common all 1.28.0-2 [53.2 kB]
Get:10 http://deb.debian.org/debian bullseye/main arm64 libpeas-1.0-0 arm64 1.28.0-2+b1 [62.4 kB]
Get:11 http://deb.debian.org/debian bullseye/main arm64 gir1.2-peas-1.0 arm64 1.28.0-2+b1 [12.7 kB]
Get:12 http://deb.debian.org/debian bullseye/main arm64 libamtk-5-common all 5.2.0-1 [7,492 B]
Get:13 http://deb.debian.org/debian bullseye/main arm64 libamtk-5-0 arm64 5.2.0-1 [22.0 kB]
Get:14 http://deb.debian.org/debian bullseye/main arm64 libgspell-1-common all 1.8.4-1 [31.9 kB]
Get:15 http://deb.debian.org/debian bullseye/main arm64 libgspell-1-2 arm64 1.8.4-1 [51.3 kB]
Get:16 http://deb.debian.org/debian bullseye/main arm64 libtepl-5-0 arm64 5.0.1-2 [90.7 kB]
Get:17 http://deb.debian.org/debian bullseye/main arm64 gedit arm64 3.38.1-1 [367 kB]
Get:18 http://deb.debian.org/debian bullseye/main arm64 libyelp0 arm64 3.38.3-1 [164 kB]
Get:19 http://deb.debian.org/debian bullseye/main arm64 yelp-xsl all 3.38.3-1 [445 kB]
Get:20 http://deb.debian.org/debian bullseye/main arm64 yelp arm64 3.38.3-1 [779 kB]
Fetched 6,846 kB in 3s (2,151 kB/s)
Selecting previously unselected package sgml-data.
(Reading database ... 92162 files and directories currently installed.)
Preparing to unpack .../00-sgml-data_2.0.11+nmu1_all.deb ...
Unpacking sgml-data (2.0.11+nmu1) ...
Selecting previously unselected package docbook-xml.
Preparing to unpack .../01-docbook-xml_4.5-9_all.deb ...
Unpacking docbook-xml (4.5-9) ...
Selecting previously unselected package fonts-dejavu-extra.
Preparing to unpack .../02-fonts-dejavu-extra_2.37-2_all.deb ...
Unpacking fonts-dejavu-extra (2.37-2) ...
Selecting previously unselected package fonts-dejavu.
Preparing to unpack .../03-fonts-dejavu_2.37-2_all.deb ...
Unpacking fonts-dejavu (2.37-2) ...
Selecting previously unselected package gedit-common.
Preparing to unpack .../04-gedit-common_3.38.1-1_all.deb ...
Unpacking gedit-common (3.38.1-1) ...
Selecting previously unselected package libgtksourceview-4-common.
Preparing to unpack .../05-libgtksourceview-4-common_4.8.0-1_all.deb ...
Unpacking libgtksourceview-4-common (4.8.0-1) ...
Selecting previously unselected package libgtksourceview-4-0:arm64.
Preparing to unpack .../06-libgtksourceview-4-0_4.8.0-1_arm64.deb ...
Unpacking libgtksourceview-4-0:arm64 (4.8.0-1) ...
Selecting previously unselected package gir1.2-gtksource-4:arm64.
Preparing to unpack .../07-gir1.2-gtksource-4_4.8.0-1_arm64.deb ...
Unpacking gir1.2-gtksource-4:arm64 (4.8.0-1) ...
Selecting previously unselected package libpeas-common.
Preparing to unpack .../08-libpeas-common_1.28.0-2_all.deb ...
Unpacking libpeas-common (1.28.0-2) ...
Selecting previously unselected package libpeas-1.0-0:arm64.
Preparing to unpack .../09-libpeas-1.0-0_1.28.0-2+b1_arm64.deb ...
Unpacking libpeas-1.0-0:arm64 (1.28.0-2+b1) ...
Selecting previously unselected package gir1.2-peas-1.0:arm64.
Preparing to unpack .../10-gir1.2-peas-1.0_1.28.0-2+b1_arm64.deb ...
Unpacking gir1.2-peas-1.0:arm64 (1.28.0-2+b1) ...
Selecting previously unselected package libamtk-5-common.
Preparing to unpack .../11-libamtk-5-common_5.2.0-1_all.deb ...
Unpacking libamtk-5-common (5.2.0-1) ...
Selecting previously unselected package libamtk-5-0:arm64.
Preparing to unpack .../12-libamtk-5-0_5.2.0-1_arm64.deb ...
Unpacking libamtk-5-0:arm64 (5.2.0-1) ...
Selecting previously unselected package libgspell-1-common.
Preparing to unpack .../13-libgspell-1-common_1.8.4-1_all.deb ...
Unpacking libgspell-1-common (1.8.4-1) ...
Selecting previously unselected package libgspell-1-2:arm64.
Preparing to unpack .../14-libgspell-1-2_1.8.4-1_arm64.deb ...
Unpacking libgspell-1-2:arm64 (1.8.4-1) ...
Selecting previously unselected package libtepl-5-0:arm64.
Preparing to unpack .../15-libtepl-5-0_5.0.1-2_arm64.deb ...
Unpacking libtepl-5-0:arm64 (5.0.1-2) ...
Selecting previously unselected package gedit.
Preparing to unpack .../16-gedit_3.38.1-1_arm64.deb ...
Unpacking gedit (3.38.1-1) ...
Selecting previously unselected package libyelp0:arm64.
Preparing to unpack .../17-libyelp0_3.38.3-1_arm64.deb ...
Unpacking libyelp0:arm64 (3.38.3-1) ...
Selecting previously unselected package yelp-xsl.
Preparing to unpack .../18-yelp-xsl_3.38.3-1_all.deb ...
Unpacking yelp-xsl (3.38.3-1) ...
Selecting previously unselected package yelp.
Preparing to unpack .../19-yelp_3.38.3-1_arm64.deb ...
Unpacking yelp (3.38.3-1) ...
Setting up gedit-common (3.38.1-1) ...
Setting up libgspell-1-common (1.8.4-1) ...
Setting up libyelp0:arm64 (3.38.3-1) ...
Setting up libpeas-common (1.28.0-2) ...
Setting up fonts-dejavu-extra (2.37-2) ...
Setting up libpeas-1.0-0:arm64 (1.28.0-2+b1) ...
Setting up sgml-data (2.0.11+nmu1) ...
Setting up libamtk-5-common (5.2.0-1) ...
Setting up libgtksourceview-4-common (4.8.0-1) ...
Setting up libgspell-1-2:arm64 (1.8.4-1) ...
Setting up yelp-xsl (3.38.3-1) ...
Setting up fonts-dejavu (2.37-2) ...
Setting up yelp (3.38.3-1) ...
Setting up libamtk-5-0:arm64 (5.2.0-1) ...
Setting up gir1.2-peas-1.0:arm64 (1.28.0-2+b1) ...
Setting up libgtksourceview-4-0:arm64 (4.8.0-1) ...
Setting up libtepl-5-0:arm64 (5.0.1-2) ...
Setting up gir1.2-gtksource-4:arm64 (4.8.0-1) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for sgml-base (1.30) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for fontconfig (2.13.1-4.2) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for libglib2.0-0:arm64 (2.66.8-1) ...
Setting up docbook-xml (4.5-9) ...
Setting up gedit (3.38.1-1) ...
update-alternatives: using /usr/bin/gedit to provide /usr/bin/gnome-text-editor (gnome-text-editor) in auto mode
Processing triggers for sgml-base (1.30) ...
Installing Qt dependencies
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package qt5-default is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'qt5-default' has no installation candidate
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
 libqt5websockets5
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 56.3 kB of archives.
After this operation, 210 kB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bullseye/main arm64 libqt5websockets5 arm64 5.15.2-2 [56.3 kB]
Fetched 56.3 kB in 0s (279 kB/s)            
Selecting previously unselected package libqt5websockets5:arm64.
(Reading database ... 95189 files and directories currently installed.)
Preparing to unpack .../libqt5websockets5_5.15.2-2_arm64.deb ...
Unpacking libqt5websockets5:arm64 (5.15.2-2) ...
Setting up libqt5websockets5:arm64 (5.15.2-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
 libegl-dev libgl-dev libglu1-mesa libglu1-mesa-dev libglx-dev
 libpthread-stubs0-dev libqt5opengl5 libqt5opengl5-dev libqt5test5
 libvulkan-dev libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxext-dev
 qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools qtchooser x11proto-dev
 x11proto-xext-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
 libx11-doc libxcb-doc libxext-doc default-libmysqlclient-dev firebird-dev
 libpq-dev libsqlite3-dev unixodbc-dev
The following NEW packages will be installed:
 libegl-dev libgl-dev libglu1-mesa libglu1-mesa-dev libglx-dev
 libpthread-stubs0-dev libqt5opengl5 libqt5opengl5-dev libqt5test5
 libqt5websockets5-dev libvulkan-dev libx11-dev libxau-dev libxcb1-dev
 libxdmcp-dev libxext-dev qt5-qmake qt5-qmake-bin qtbase5-dev
 qtbase5-dev-tools qtchooser x11proto-dev x11proto-xext-dev
 xorg-sgml-doctools xtrans-dev
0 upgraded, 25 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,420 kB of archives.
After this operation, 44.6 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bullseye/main arm64 xorg-sgml-doctools all 1:1.11-1.1 [22.1 kB]
Get:2 http://deb.debian.org/debian bullseye/main arm64 x11proto-dev all 2020.1-1 [594 kB]
Get:3 http://deb.debian.org/debian bullseye/main arm64 libxau-dev arm64 1:1.0.9-1 [23.2 kB]
Get:4 http://deb.debian.org/debian bullseye/main arm64 libxdmcp-dev arm64 1:1.1.2-3 [41.2 kB]
Get:5 http://deb.debian.org/debian bullseye/main arm64 xtrans-dev all 1.4.0-1 [98.7 kB]
Get:6 http://deb.debian.org/debian bullseye/main arm64 libpthread-stubs0-dev arm64 0.4-1 [5,336 B]
Get:7 http://deb.debian.org/debian bullseye/main arm64 libxcb1-dev arm64 1.14-3 [177 kB]
Get:8 http://deb.debian.org/debian bullseye/main arm64 libx11-dev arm64 2:1.7.2-1 [828 kB]
Get:9 http://deb.debian.org/debian bullseye/main arm64 libglx-dev arm64 1.3.2-1 [16.3 kB]
Get:10 http://deb.debian.org/debian bullseye/main arm64 libgl-dev arm64 1.3.2-1 [100 kB]
Get:11 http://deb.debian.org/debian bullseye/main arm64 libegl-dev arm64 1.3.2-1 [19.6 kB]
Get:12 http://deb.debian.org/debian bullseye/main arm64 libglu1-mesa arm64 9.0.1-1 [146 kB]
Get:13 http://deb.debian.org/debian bullseye/main arm64 libglu1-mesa-dev arm64 9.0.1-1 [186 kB]
Get:14 http://deb.debian.org/debian bullseye/main arm64 libqt5opengl5 arm64 5.15.2+dfsg-9 [167 kB]
Get:15 http://deb.debian.org/debian bullseye/main arm64 libqt5test5 arm64 5.15.2+dfsg-9 [156 kB]
Get:16 http://deb.debian.org/debian bullseye/main arm64 libvulkan-dev arm64 1.2.162.0-1 [586 kB]
Get:17 http://deb.debian.org/debian bullseye/main arm64 x11proto-xext-dev all 2020.1-1 [3,404 B]
Get:18 http://deb.debian.org/debian bullseye/main arm64 libxext-dev arm64 2:1.3.3-1.1 [107 kB]
Get:19 http://deb.debian.org/debian bullseye/main arm64 qt5-qmake-bin arm64 5.15.2+dfsg-9 [913 kB]
Get:20 http://deb.debian.org/debian bullseye/main arm64 qtchooser arm64 66-2 [24.9 kB]
Get:21 http://deb.debian.org/debian bullseye/main arm64 qt5-qmake arm64 5.15.2+dfsg-9 [249 kB]
Get:22 http://deb.debian.org/debian bullseye/main arm64 qtbase5-dev-tools arm64 5.15.2+dfsg-9 [716 kB]
Get:23 http://deb.debian.org/debian bullseye/main arm64 qtbase5-dev arm64 5.15.2+dfsg-9 [1,148 kB]
Get:24 http://deb.debian.org/debian bullseye/main arm64 libqt5opengl5-dev arm64 5.15.2+dfsg-9 [77.9 kB]
Get:25 http://deb.debian.org/debian bullseye/main arm64 libqt5websockets5-dev arm64 5.15.2-2 [15.0 kB]
Fetched 6,420 kB in 3s (2,197 kB/s)                
Selecting previously unselected package xorg-sgml-doctools.
(Reading database ... 95195 files and directories currently installed.)
Preparing to unpack .../00-xorg-sgml-doctools_1%3a1.11-1.1_all.deb ...
Unpacking xorg-sgml-doctools (1:1.11-1.1) ...
Selecting previously unselected package x11proto-dev.
Preparing to unpack .../01-x11proto-dev_2020.1-1_all.deb ...
Unpacking x11proto-dev (2020.1-1) ...
Selecting previously unselected package libxau-dev:arm64.
Preparing to unpack .../02-libxau-dev_1%3a1.0.9-1_arm64.deb ...
Unpacking libxau-dev:arm64 (1:1.0.9-1) ...
Selecting previously unselected package libxdmcp-dev:arm64.
Preparing to unpack .../03-libxdmcp-dev_1%3a1.1.2-3_arm64.deb ...
Unpacking libxdmcp-dev:arm64 (1:1.1.2-3) ...
Selecting previously unselected package xtrans-dev.
Preparing to unpack .../04-xtrans-dev_1.4.0-1_all.deb ...
Unpacking xtrans-dev (1.4.0-1) ...
Selecting previously unselected package libpthread-stubs0-dev:arm64.
Preparing to unpack .../05-libpthread-stubs0-dev_0.4-1_arm64.deb ...
Unpacking libpthread-stubs0-dev:arm64 (0.4-1) ...
Selecting previously unselected package libxcb1-dev:arm64.
Preparing to unpack .../06-libxcb1-dev_1.14-3_arm64.deb ...
Unpacking libxcb1-dev:arm64 (1.14-3) ...
Selecting previously unselected package libx11-dev:arm64.
Preparing to unpack .../07-libx11-dev_2%3a1.7.2-1_arm64.deb ...
Unpacking libx11-dev:arm64 (2:1.7.2-1) ...
Selecting previously unselected package libglx-dev:arm64.
Preparing to unpack .../08-libglx-dev_1.3.2-1_arm64.deb ...
Unpacking libglx-dev:arm64 (1.3.2-1) ...
Selecting previously unselected package libgl-dev:arm64.
Preparing to unpack .../09-libgl-dev_1.3.2-1_arm64.deb ...
Unpacking libgl-dev:arm64 (1.3.2-1) ...
Selecting previously unselected package libegl-dev:arm64.
Preparing to unpack .../10-libegl-dev_1.3.2-1_arm64.deb ...
Unpacking libegl-dev:arm64 (1.3.2-1) ...
Selecting previously unselected package libglu1-mesa:arm64.
Preparing to unpack .../11-libglu1-mesa_9.0.1-1_arm64.deb ...
Unpacking libglu1-mesa:arm64 (9.0.1-1) ...
Selecting previously unselected package libglu1-mesa-dev:arm64.
Preparing to unpack .../12-libglu1-mesa-dev_9.0.1-1_arm64.deb ...
Unpacking libglu1-mesa-dev:arm64 (9.0.1-1) ...
Selecting previously unselected package libqt5opengl5:arm64.
Preparing to unpack .../13-libqt5opengl5_5.15.2+dfsg-9_arm64.deb ...
Unpacking libqt5opengl5:arm64 (5.15.2+dfsg-9) ...
Selecting previously unselected package libqt5test5:arm64.
Preparing to unpack .../14-libqt5test5_5.15.2+dfsg-9_arm64.deb ...
Unpacking libqt5test5:arm64 (5.15.2+dfsg-9) ...
Selecting previously unselected package libvulkan-dev:arm64.
Preparing to unpack .../15-libvulkan-dev_1.2.162.0-1_arm64.deb ...
Unpacking libvulkan-dev:arm64 (1.2.162.0-1) ...
Selecting previously unselected package x11proto-xext-dev.
Preparing to unpack .../16-x11proto-xext-dev_2020.1-1_all.deb ...
Unpacking x11proto-xext-dev (2020.1-1) ...
Selecting previously unselected package libxext-dev:arm64.
Preparing to unpack .../17-libxext-dev_2%3a1.3.3-1.1_arm64.deb ...
Unpacking libxext-dev:arm64 (2:1.3.3-1.1) ...
Selecting previously unselected package qt5-qmake-bin.
Preparing to unpack .../18-qt5-qmake-bin_5.15.2+dfsg-9_arm64.deb ...
Unpacking qt5-qmake-bin (5.15.2+dfsg-9) ...
Selecting previously unselected package qtchooser.
Preparing to unpack .../19-qtchooser_66-2_arm64.deb ...
Unpacking qtchooser (66-2) ...
Selecting previously unselected package qt5-qmake:arm64.
Preparing to unpack .../20-qt5-qmake_5.15.2+dfsg-9_arm64.deb ...
Unpacking qt5-qmake:arm64 (5.15.2+dfsg-9) ...
Selecting previously unselected package qtbase5-dev-tools.
Preparing to unpack .../21-qtbase5-dev-tools_5.15.2+dfsg-9_arm64.deb ...
Unpacking qtbase5-dev-tools (5.15.2+dfsg-9) ...
Selecting previously unselected package qtbase5-dev:arm64.
Preparing to unpack .../22-qtbase5-dev_5.15.2+dfsg-9_arm64.deb ...
Unpacking qtbase5-dev:arm64 (5.15.2+dfsg-9) ...
Selecting previously unselected package libqt5opengl5-dev:arm64.
Preparing to unpack .../23-libqt5opengl5-dev_5.15.2+dfsg-9_arm64.deb ...
Unpacking libqt5opengl5-dev:arm64 (5.15.2+dfsg-9) ...
Selecting previously unselected package libqt5websockets5-dev:arm64.
Preparing to unpack .../24-libqt5websockets5-dev_5.15.2-2_arm64.deb ...
Unpacking libqt5websockets5-dev:arm64 (5.15.2-2) ...
Setting up libvulkan-dev:arm64 (1.2.162.0-1) ...
Setting up libpthread-stubs0-dev:arm64 (0.4-1) ...
Setting up xtrans-dev (1.4.0-1) ...
Setting up qt5-qmake-bin (5.15.2+dfsg-9) ...
Setting up libqt5opengl5:arm64 (5.15.2+dfsg-9) ...
Setting up xorg-sgml-doctools (1:1.11-1.1) ...
Setting up libglu1-mesa:arm64 (9.0.1-1) ...
Setting up libqt5test5:arm64 (5.15.2+dfsg-9) ...
Setting up qtchooser (66-2) ...
Setting up qt5-qmake:arm64 (5.15.2+dfsg-9) ...
Setting up qtbase5-dev-tools (5.15.2+dfsg-9) ...
Processing triggers for sgml-base (1.30) ...
Setting up x11proto-dev (2020.1-1) ...
Setting up libxau-dev:arm64 (1:1.0.9-1) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Processing triggers for man-db (2.9.4-2) ...
Setting up libxdmcp-dev:arm64 (1:1.1.2-3) ...
Setting up x11proto-xext-dev (2020.1-1) ...
Setting up libxcb1-dev:arm64 (1.14-3) ...
Setting up libx11-dev:arm64 (2:1.7.2-1) ...
Setting up libxext-dev:arm64 (2:1.3.3-1.1) ...
Setting up libglx-dev:arm64 (1.3.2-1) ...
Setting up libgl-dev:arm64 (1.3.2-1) ...
Setting up libegl-dev:arm64 (1.3.2-1) ...
Setting up libglu1-mesa-dev:arm64 (9.0.1-1) ...
Setting up qtbase5-dev:arm64 (5.15.2+dfsg-9) ...
Setting up libqt5websockets5-dev:arm64 (5.15.2-2) ...
Setting up libqt5opengl5-dev:arm64 (5.15.2+dfsg-9) ...
Creating shortcuts...
rm: cannot remove '/root/Desktop/RoboDK.desktop': No such file or directory
./Create-Shortcut.sh: 6: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 7: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 8: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 9: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 10: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 11: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 12: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 13: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
./Create-Shortcut.sh: 14: cannot create /root/Desktop/RoboDK.desktop: Directory nonexistent
rm: cannot remove '/root/RoboDK/RoboDK.desktop': No such file or directory
Installing RoboDK for Python 2 and Python 3...
Installing RoboDK for Python 2 and Python 3...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
python3 is already the newest version (3.9.2-3).
python3 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
 idle idle-python3.9
The following NEW packages will be installed:
 idle idle-python3.9 idle3
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 361 kB of archives.
After this operation, 1,401 kB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bullseye/main arm64 idle-python3.9 all 3.9.2-1 [357 kB]
Get:2 http://deb.debian.org/debian bullseye/main arm64 idle all 3.9.2-3 [2,820 B]
Get:3 http://deb.debian.org/debian bullseye/main arm64 idle3 all 3.9.2-3 [956 B]
Fetched 361 kB in 0s (1,187 kB/s)
Selecting previously unselected package idle-python3.9.
(Reading database ... 98466 files and directories currently installed.)
Preparing to unpack .../idle-python3.9_3.9.2-1_all.deb ...
Unpacking idle-python3.9 (3.9.2-1) ...
Selecting previously unselected package idle.
Preparing to unpack .../archives/idle_3.9.2-3_all.deb ...
Unpacking idle (3.9.2-3) ...
Selecting previously unselected package idle3.
Preparing to unpack .../archives/idle3_3.9.2-3_all.deb ...
Unpacking idle3 (3.9.2-3) ...
Setting up idle-python3.9 (3.9.2-1) ...
Setting up idle (3.9.2-3) ...
Setting up idle3 (3.9.2-3) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
python3-pip is already the newest version (20.3.4-4+rpt1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting robodk
 Downloading robodk-5.4.0-py2.py3-none-any.whl (96 kB)
    |████████████████████████████████| 96 kB 986 kB/s
Installing collected packages: robodk
Successfully installed robodk-5.4.0
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
Collecting robodk
 Using cached robodk-5.4.0-py2.py3-none-any.whl (96 kB)
 Downloading robodk-5.3.1-py2.py3-none-any.whl (83 kB)
    |████████████████████████████████| 83 kB 433 kB/s
You can delete the RoboDK install folder now

Done!
Optionally start RoboDK behind the scenes by typing:
/root/RoboDK/RoboDK-Start-Hidden.sh

Optionally start RoboDK as a service on startup:
/root/RoboDK/Create-RoboDK-Service.sh

Start RoboDK by typing:
/root/RoboDK/RoboDK-Start.sh
root@titus:/home/pi/Desktop/Install-RoboDK-Pi#

Here follows the script output for the dependencies installation: 

Code:
pi@titus:~ $ sudo su
root@titus:/home/pi# cd Desktop/Install-RoboDK-Pi/RoboDK-Pi
root@titus:/home/pi/Desktop/Install-RoboDK-Pi/RoboDK-Pi# sudo ./Install-RoboDK-Dependencies.sh
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package python3-pip
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: robodk in /usr/local/lib/python3.9/dist-packages (5.4.0)
: not foundoboDK-Dependencies.sh: 6:
Reading package lists... Done
E: Unable to find a source package for qt4-x11
Reading package lists... Done
E: Unable to find a source package for libqt5gui5
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libinput-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libxcb-xinerama0
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libtspi-dev
: not foundoboDK-Dependencies.sh: 14:
root@titus:/home/pi/Desktop/Install-RoboDK-Pi/RoboDK-Pi#
  




Users browsing this thread:
1 Guest(s)