Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect to UR5
#11
Hi Liushuya,

I recommend you to try it on a Windows computer and completely turn off your Windows firewall as shown in the attached image.

Also, I noticed in your logs that the robot IP is not consistent... sometimes you use 192.168.38.2 and sometimes you use 192.168.1.10. Make sure you have the correct robot IP and you properly established a LAN between your PC and the robot. This may require you changing the IP of your network card. 

More information here:
https://robodk.com/doc/en/Robots-Univers...html#UR-IP
https://robodk.com/doc/en/Robot-Drivers....taticIP-PC

   

We are fixing an issue with UR driver on a Mac and an update will be available before the end of the year.
#12
Hi Albert,

Thanks for your reply. In fact, I have done that. I have completely turned off my Windows firewall. But it still always gives me "waiting...".
The IP has been consistent. The reason you saw different connecting IP there is because I have tried to change the static IP address on the robot hoping to make it work. However, nothing happened.
Could you, by any chance, share the "progrobodk.script" file with me? I'm wondering if I can just upload it to UR10 through FTP, then run that script manually on PolyScope.

Thanks,
Joshua
#13
Hi Joshua,

Do you see any errors/warnings on the log panel of the UR teach pendant?

If not, you can send us an email at:
info@robodk.com
And we'll provide you with instructions for further testing.

Thanks,

Albert
#14
Can you kindly provide a driver for UR CB2?

Thanks,
Joshua
#15
I have the same problem and did everything written above to solve it, but it did not help. But one thing I have noticed is that even though there is no connection still, when I run the UR_monitoring_CSV macro, at first second the UR5 robot in simulation takes the pose as the real one but does not follow afterwards. I have tried to change the pose of real one and re-run the macro, everythins is repeated. So, somehow RoboDK is connected to the UR5 but not connected.
#16
Make sure to change this setting if you have an older UR robot:
http://robodk.com/forum/Thread-Connect-t...585#pid585
#17
Hi Albert,
I have changed the controller version and turned off the firewall of windows, but stil cannot connect to UR5. I have done everything written in this thread. I would appreciate any help.

Best Regards,

mnurpeiissov
#18
Hi mnurpeiissov,

Sorry to read the issues you are experiencing, same thing for everyone else above.

We will try to help you, but you need to understand that it's not that easy to help with that kind of problem from a distance.
We can guarantee you that we many of our users connect to UR robots using RoboDK.

I'm gonna ask you a few questions to start with. I'm sorry if you already gave that information before.

1 - Which version of UR controllers are you using?
2 - Are you directly connected to the robot using an Ethernet cable or do you go through a switch?
3 - Are you able to ping the controller? From your terminal and from RoboDK.
4 - Did you try with more than one PC?
5 - Did you download a fresh version of RoboDK from our web site and use it to make sure that you have the latest version?
6 - Is there any update available for your robot controller?

I will also ask, if anyone had those kinds of issues and solve it, please write down what you did to solve your problem.
Our goal is to gather as much information as possible.

Have a good day.
Jeremy
#19
Hi Jeremy,

Sorry for the late answers.

1) In the apiur.exe file I have tried with both controller version 1 and 3. The Polyscope version is 1.8.16941 (February 10 2015)
2) I have directly connected to UR5 from my laptop
3) I can ping the IP adress of UR5 both from terminal and from RoboDK. I could browse the UR5 using FireZilla.
4) No, I have tried only with my laptop
5) Yes , I have downloaded the fresh version of RoboDK
6) No, I did not have checked for available update

Best Regadrds,

mnurpeiissov
#20
Hi mnurpeiissov,

Thanks for the information.
1 - OK
2 - Good sign
3 - Good sign
4 - Is it a personal laptop? Or is it a company/school one?
I'm pointing that out because company/school computers have some time more security on top of the normal windows firewall.
And if it's a personal one, could you have an antivirus/firewall on top of windows firewall?

Could you try 4 and 6?

Have a good day.
Jeremy
  




Users browsing this thread:
1 Guest(s)