Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect to UR5
#1
Hi All.

I am attempting to connect to a UR5 for the first time to get the position, but am unable to successfully connect. I can ping the UR5 controller without issue, but the connection status bar never turns green, instead stopping at "Waiting...". From the attached screen shot, is anyone able to comment on what it is I am doing wrong?

The controller is a CB3 running SW1.3 and we are running PolyScope 1.8.16941


Attached Files Thumbnail(s)
   
#2
The RoboDK driver for Universal Robots will not work with Polyscope Version 1.8 and earlier by default. However, you can change the following setting:
CONTROLLER_VERSION=1

In the file:
%APPDATA%/RoboDK-Drivers/apiur.exe.ini

   

The main difference is that previous versions do not support changing digital outputs through the driver.
#3
Brilliant - thank you for that.
#4
Unfortunately it appears I spoke too soon. Making the recommended change to the .ini file (and setting the timeout to 5000ms) results in the following RoboDK log output:

Disconnected
Stopped
Starting robot driver: C:/RoboDK/api/robot/apiur.exe
Starting...
CONNECT 192.168.0.1 30002 6
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 1
Communication Timeout (ms): 5000
Disconnected
Available local IP addresses (IPv4):
132.181.60.62
192.168.0.10
Server stablished at: 192.168.0.10:30002
Warning: Using older controller compatibility (IO not supported)
Connected to 192.168.0.1:30002. Sending program :/progrobodk_basic.script...
Updating computer IP on program: 192.168.0.10
Updating computer port on program: 30002
Program sent.
Waiting...

Note that I can ping the controller, and explore its file system from within RoboDk using FileZilla, but I am unable to connect to the robot. Any other suggestions as to what may be causing the issue?

Update: I have pushed the latest version of PolyScope (1.8.25319) onto the controller, but this has not improved the situation. I have used FileZilla to search for the 'progrobodk_basic.script' file on the controller after RoboDK said it had been sent, but can find no evidence of the file on the controller.
#5
I have replaced the UR5 with one with a CB3 controller, and I still cannot connect to the UR5 from RoboDK. As was  previously the case, I can ping the controller and FTP to it using FileZilla, but I cannot connect. Log output is as follows:

Stopped
Stopped
Starting robot driver: C:/RoboDK/api/robot/apiur.exe
Starting...
CONNECT 192.168.1.1 30000 6
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 3
Communication Timeout (ms): 1000
Disconnected
Available local IP addresses (IPv4):
132.181.60.62
192.168.1.10
Server stablished at: 192.168.1.10:30000
Connected to 192.168.1.1:30002. Sending program :/progrobodk.script...
Updating computer IP on program: 192.168.1.10
Updating computer port on program: 30000
Program sent.
Waiting...

Any advice on how to solve this issue would be gratefully received!

Problem solved! It turns out it was a Windows Firewall issue. I had rules for TCP and UDP on port 30000, but that was not enough. Once I added a rule for all protocols everything worked.
#6
Great!
It is a good idea to turn Windows Firewall OFF to troubleshoot communication issues with the robot.
Once the communication is properly stablished you can add an exception for the robot driver.
#7
Try to turn Windows Firewall OFF to troubleshoot communication issues with the robot.
yahoo mail sign up
#8
Hello everybody,
I am facing similiar issues with UR3.
What I have tried:
- turning off firewall on Windows 10
- upgrading robotdk to most recent version
- changing parameter inside the driver ini file
- different IP settings both on robot side and PC side.
I can ping the UR3, but nothing else is really working as I am stuck on "Program sent... Waiting...".

Any ideas what I can do more to solve this issue?
#9
Hello!
Just wanted to say that i´ve also tryed everything of the above (switch Firewall off, Change Ini File) and have the same Problem over here.
The Robot is in the same subnet and i can ping it aswell, but when i try to connect it is stuck on "waiting..."
It is an UR5 with an CB2 Controller, running URControl/Polyscope 1.8.23117.
Greetz
#10
Hi,

I also did everything following the discussion above. But I'm still getting the exact same "waiting" frustration. Can anyone explain how to make the connection working in details?
Below is my connection log:
Code:
Starting robot driver: D:/RoboDK/api/robot/apiur.exe
Starting...
CONNECT 192.168.38.2 30000 6
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 1
Communication Timeout (ms): 1000
Disconnected
Available local IP addresses (IPv4):
10.176.186.183
192.168.10.1
192.168.205.1
192.168.38.101
Server stablished at: 192.168.38.101:30000
Warning: Using older controller compatibility (IO not supported)
Connected to 192.168.38.2:30002. Sending program :/progrobodk_basic.script...
Updating computer IP on program: 192.168.38.101
Updating computer port on program: 30000
Program sent.
Waiting...
I couldn't find progrobodk_basic.script. But I had no problem sending other programs (e.g. DrawHex.script)
Code:
Connected to 192.168.1.10:30002. Sending program /DrawHex.script...
Program sent.
Program sent to robot.
Ready
Below is what I got when I was trying to connect to UR10 on Mac:
Code:
Starting robot driver: /Applications/RoboDK.app/Contents/MacOS/apiur
Starting...
CONNECT 192.168.1.10 30000 6
Error: Error writing to process (id 4)
Driver apiur not running
Disconnected
Unexpected error: dyld: Library not loaded: @rpath/QtNetwork.framework/Versions/5/QtNetwork
Unexpected error: Referenced from: /Applications/RoboDK.app/Contents/MacOS/apiur
Unexpected error: Reason: image not found
Error: Process crashed (id 1)
Stopped
Robot: UR10
Controller: CB2
Interface: PolyScope 1.8.25319
----------------
I also followed this article on Open Firewall Ports In Windows 10. But it still doesn't change anything.
Can anyone send me the progrobodk_basic.script file? Any help would be really appreciated!!

Thanks,
Josh
  




Users browsing this thread:
1 Guest(s)