Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Fanuc R30ia No application data

Hi ! I have a probleme with teach pendant program on a Fanuc robot. I use R30ia post processor and i have a NO APPLICATION DATA error on teach pendant. I put the program in attachment.


.txt   Path2.txt (Size: 22.94 KB / Downloads: 310)
Can you provide more details about this issue?
I assume you are loading the LS program file using FTP or a USB drive.
Do you see the No application data issue when you load the file or when you try to run it?

If you can provide a picture of your teach pendant it may help us help you troubleshoot.
        Here is a picture of the erroro code and a picture of the application data, it is on a LS programme from usb key.
I can load the programme on the robot but when we try to start in auto mode we have this code.
Hi Albert, 

I'll do my best to explain the situation that we are living with our Fanuc R2000iA/210F here at IRIDIUM CNC.

As you saw in the provided picture, we have the ''No application data'' error. I'll explain what we did up to this day.

1. User frame calibration (on the real robot)
2. Tool frame calibration (on the real robot)
3. We can open the program (in .LS) on the FR disk once loaded with a usb key. I'm guessing we don't have any problem with the  ASCII upload for the .TP compilation. Once we are seeing the program on the screen, we press the green ''cycle start'' button and then ''enter''. It's at this moment that the error is appearing.

Note: the Uframe and Toolframe ID both corresponding on the TP and on the program file.

So right now, we are pretty lost in this adventure wich is to make the robot excecute a simple offline program.
We can provide any other informations that you need to help us find the solution or trouble shoot.

We are out of solutions for the moment. Thanks for helping us.

Here a exemple of what I tried this morning.(see the program in the attachment).
Following as we are about to use a RoboDK program, ASCII Upload to an R30ia controller driving a Fanuc R2000ib/210F. I really hope this isn't a systemic issue as this will be our first attempt at RoboDK to Fanuc ASCII Upload.
I'm sorry we took so long to get back to you on this issue. Taking a look at the Fanuc programming manual we can see the following information:

INTP-281 No application data
  • Cause: This program doesn't have the application data
  • Remedy: Please define the application data in the program detail screen

I believe "Application data" can refer to many things such as the tool and reference frame, external axes, additional controller options. 

Tool and reference:
You shared an image where we can clearly see that you are using Tool 1 on your teach pendant (UTOOL number 1). Can you verify you properly defined the reference frame number 1 (UFRAME 1)?

For your information, you can see towards the top of your program what UFRAME and UTOOL numbers you are using. If your tool is called "Tool 1" it will use the number of the tool as the UTOOL Index. The same applies to the reference frame.

 8:  UFRAME_NUM=1 ;
 9:  ! UF1:1727.6,-155.7,19 ; 1.2 , 0.0,0.1,0.2 ;
11:  UTOOL_NUM=1 ;
12:  ! UT1:-248.2,-144.9,71 ; .1,-111.5,4.0,120.3 ;

External axes:
Do you have any external axes? If so, they should also be available in RoboDK and properly synchronized. Also, do you have more than one robot controlled by the same controller?

It would help you can provide a valid robot program (an LS file generated with the teach pendant of your Fanuc robot controller). We can take a look at the header and check the differences with RoboDK's default program header.

please check the attached file and video,
we do not have external axes and the tool number and user frame number correspond to those defined in the controller 



Attached Files
.txt   test.txt (Size: 2.69 KB / Downloads: 140)
.mp4   video-42fe6593-0ee8-49a2-b529-92d02705470d-1662991307.mp4 (Size: 11.31 MB / Downloads: 136)
We just solved this issue with our robot cell.

We have ArcTool and multiple motion groups in our setup, and got the NO APPLICATION DATA error every time that we tried to run a program exported from RoboDK. In order to bypass the error, at first, we simply accessed the program's detail screen on the teach pendant, and hit "NEXT" to get to the application data page. We could simply exit the detail screen at that point and run the program and the error wouldn't occur again.

A better method we found was to insert the required application data into the /APPL section of the program header (via the FANUC R30iA post processor). There was little to no FANUC documentation on what info/syntax to input. Instead, we manually created a program on the teach pendant, then exported it as an ASCII file (.ls) onto a usb drive and read the file on our computer. That's where we found the needed application data.

I've attached an image of the functional program header with application data inserted.

Attached Files Thumbnail(s)
Thank you for this information. We'll be adding the APPLICATION_DATA variable to Fanuc post processors with our next update in the next few days. You'll be able to configure the post with custom lines that will be output inside the /APPL section of the header. 

For example:

APPLICATION_DATA = ['ARC : TRUE;' , 'ARC Welding Equipment : 1,*,*,*,*;']
You may need to generate a program with your controller first to see what header the controller expects. If you can send us an empty LS file generated by your controller we can help you better.

Users browsing this thread:
1 Guest(s)