Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

I need fresh eyes and help on a robot cell, the coordinates are wrong

Hi Guys

I hope you are well :)

I have build a robot cell, and it seems to be working fine, untill i transfer the program to the robot, then it goes wrong


When i upload the program to the robot it tries to reach a possition in the carthesian frame, that it cannot, even though it looks right in RDK
Im pretty sure it is a minor detail im missing somewhere, so i hope you will take a look at it, and hopefully you can figure out what i have messed up :)
When i move the robot in "WorkFrame1RDK" space. if i move the X Axis, it moves in the X direction, but the coordinate on the robot frame it is the numbers for the Z Axis that moves, not the X Axis (Like the axis for the manipulator is set to)

Here is what i have tried:
  • I have tried to redefine the TCP, no effect, it is basicaly the same place as it is now, and with the same orientation
  • I have tried with the TCP redefined, to define the working frame "WorkFrame1RDK" No change
  • I have made sure that all the frames are pointing in the same direction as the robot's frame, with the exception of the manipulator it self (The frame for the manipulator is pointing the right way)

But if i transfer the targets in Joint configuration (MoveJAbs) then there is no problem, and the robot moves where it is supposed to move. it is only in the carthesian coordinates i have the problem.

I have attatched the .rdk file

Thanks in advance

.rdk   RobotCelle1_12012024_139130.rdk (Size: 4.6 MB / Downloads: 68)
When using a synchronized rotary axis, the base of the robot moves to it:


You could try using a ref. frame attached to a rotary axis for the welding program (eg. Vugge Frame):


Also, it's necessary to specify the mechanical unit name same as on the controller side.

As it is the default postprocessor parameter, you can activate the Post processor editor plugin:

  1. Tools->Addins->Post Processor Editor
  2. Program-> Post Processor Editor-> (for example)
  3. Set the necessary name for the 'MECHANICAL_UNIT_NAME' parameter:


You can then try using the saved postprocessor.

Users browsing this thread:
1 Guest(s)