Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Remote TCP - Inverse Setup Problem

#1
Hi,

I have a pellet-based extrusion setup for Large Format Additive Manufacturing (LFAM). In this setup extruder is used as a fixed tool and bed frame is attached to the KUKA KR10 robotic arm via a mounting flange.

The problem with the simulation is it doesn't move down for positive z-values. I also tried with "robot holds object" option, but it crashes every time while running the program.

I attached two rdk file, one with the default option, another with the  "robot holds object" feature. I also attached a picture where you can how it moves up along with the z-axis during printing simulation.

Thanks,
Aywan


Attached Files Thumbnail(s)
   

.rdk   LFAM Extruder11.rdk (Size: 2.71 MB / Downloads: 155)
.rdk   LFAM Extruder12.rdk (Size: 6.54 MB / Downloads: 122)
#2
It looks like your program only has Extruder calls which provokes a crash. We'll try to prevent this crash from happening but your program looks very strange as it mostly has calls to the Extruder function.

What type of file did you load in your 3D print settings? Can you provide it?
#3
One suggestion, I noticed that the 3D model of your cell was imported in a strange manner. I recommend you to simplify the geometry by following these steps:
  1. Select Tools-Options
  2. Select the Display tab
  3. Select Simplify Object...
  4. Select the object you want to simplify and select OK.
    You can repeat this operation for the other objects or select the root of your station to apply this to all objects.
You'll see the 3D navigation and simulation is much faster.
#4
I used python programming in such a way that it merged the src and dat file together so that it is more readable and can be known what is going on right now. I am attaching a screenshot to show how the src file looks like after combining with dat file.

KUKA can read this program and execute the specified commands. I can also load the file into RoboDK's default algorithm to visualize the simulation. However, when I attempt to load this file for utilizing the "robot holds object" feature to visualize the intended simulation, it crashes every time.


Attached Files Image(s)
   

.src   LFAMDemoV08_NoseCone.src (Size: 1.29 MB / Downloads: 109)
#5
I recommend you to take a look at the following example which allows you to customize the import of SRC files:
https://robodk.com/doc/en/PythonAPI/exam...a-src-file

The curve follow project was not designed to read SRC files. You should use files made for machining instead (NC/Gcode/APT). Or import SRC files directly in your project.

By the way, we fixed the crash issue you mentioned in your first post with the latest version published on Friday.
#6
Hi, I tried importing G-code like you suggested. It worked fine with the 'robot holds object' feature. Now it moves down along the z-axis as it was supposed to do.
However, I'm encountering a new problem. The first couple of lines of the program are generated right at the top of the simulation part. It might be a z-offset issue, but I couldn't figure out the problem. I've attached the RDK file for you to take a look at. Thanks!


Attached Files
.rdk   LFAM Extruder13.rdk (Size: 9.84 MB / Downloads: 129)
#7
Can you share the G-code file? We can help you better.
#8
It is saying "The type of file that you attached is not allowed." So I posted a link of the Gcode.
#9
We are unable to take the file from the link you shared, can you attach the file as a ZIP file?
#10
Here you go.


Attached Files
.zip   LFAM ToolPath.zip (Size: 354.21 KB / Downloads: 97)
  




Users browsing this thread:
1 Guest(s)