Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK will not connect to KUKA KR6 robot
Im refreshing this post since  my problem is similar to described here.
I also had problem with config file but this is now solved thanks to this thread.
Im connecting to KRC4 compact and ping is working, Windows defender disabled.
Im using Windows 10 and RoboDK 4.2.3
On Kuka Im running Kukavarproxy 9.0.0 I also tried v6.1.101 with the same result.

I think I have problem on the PC side.
1. I tried to install vcredist_x86 2008 - but it said I have a newer version installed on my PC (I had Visual Studio 2013 installed previously to use for Beckhoff PLC), then I installed  vcredist_x86 2013. 
2. After I couldnt connect I found out two error messages about missing dlls:
I downloaded these from the net and loaded to my system32 folder.
3. After I tried to connect there is error:
apikuka.exe Couldnt find insert point
Cant find insert point procedure ??0QMutex@QEAA@XZ in C:\WINDOWS\SYSTEM32\QT5Network.dll
Im attching sreen from the details of my connection in RoboDK.

My quess I have bad dll drivers for this Kukaapi
I will try to use my old Win 7 computer for that but I will first have to bring it from the office - I need couple days foir that so I thought in the mean time meybe there is a solution for that.

Thanks in advance for any help.

Attached Files Thumbnail(s)
Hi Tom,

To troubleshoot the driver you can take the DLLs from this folder:
(or just copy the EXE file there so it finds the required DLLs)

However, the result should be the same if you are connecting to the robot from RoboDK (you should not need to test the driver manually unless you are developing your own driver).

Hallo, Thank you for your response.
Yes I added this path to system and drivers problem is solved.
However I still cant connect.
I will do some more test today also with anothyer laptop and will let you know how it goes.

I have made the connection, thanks for your help.
I can get the robot position. 
When I try to move my robot there is a problem. I see that my joints read from the robot are correct - everything like in robot controller.
program RoboDKsync35 in Auto mode, config is fine.
When I move the robot with a mouse in RoboDK and press Move joints it says working, it is sending new  position and robot is not moving. But after a while it is green again and says ready.
Ive checked that I have T0 and B0 in robot controler.
Any advice how to get it moving with online programming?

Attached Files Thumbnail(s)

Users browsing this thread:
1 Guest(s)