Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with connexion with Staubli robot
#1
Hello,

I am trying to connect to a Staubli robot so that I can retrieve its current position in RoboDK.

I opened the connection window, entered the robot's IP address, the PING test is ok.

When I click on Connect, the connection status changes to Working and then Disconnected. No other message appears. I have tried the various ports mentioned in the other Threads (5653, 851, 852, 853, 854), still the same result.

   

The robot is a Staubli RX160 CS8C.

I have not changed the other connection parameters.

Did I forget something? Is there something to install or activate on the robot?
For information, I do not have the RoboDK license yet so I work with the Limited version. Is that the problem ?
#2
We just released yesterday a new update that improves our driver for Staubli (improved by @Phillip). I strongly recommend you to update RoboDK and try with that version. Make sure to properly retrieve the port from your controller as explained here:
https://robodk.com/forum/Thread-How-can-...948#pid948

For your information, you should also be able to generate VAL3 programs offline and send them through FTP.
#3
Thank you Albert for your answer.

I had actually made the update this morning before posting on the forum to be sure to have the latest updates.

I don't understand where to find the port number. I looked for the /log/system.log folder on the robot's FTP but I can't find it.

Using the following parameters:
IP / COM robot = "192.168.8.61/usr" and Port = "21",
I manage to make the connection to the FTP work via the Explore button (filezilla opens and connects me to the robot's FTP).

However, the Connect button does not work better.

Thanks in advance for your help.
#4
Hello, the port should be 5653, any staubli robot you get from our library should default to that port.
  




Users browsing this thread:
1 Guest(s)