Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robotiq Gripper 2F-85 Integration and control with UR10e in RoboDK

I am using RoboDK Python API to run my Robot UR10e and Robotiq Gripper 2f-85. UR10e movements are good enough but gripper integrations and control isn't working fine. 

I have been following RoboDK and this Robotiq Gripper Integration and Control is more frequent problem in most threads. I am having the same issue, I have tried it with documentation of the RobotiQ Gripper but it's still not working. 

rq_move_and_wait( 0 )
rq_move_and_wait( 255 ) 

These commands are not helpful. Nothing happens when we execute these files, infact RoboDK says no such program exists. (Reference 1.PNG)

Secondly, as told by RoboDK Instructor, we need to add Robotiq Mechanism for Gripper, I added that but do we also need to connect it? (Reference 2.PNG)

I came to one other method of socket connection, but when I ran my script of Gripper Activate/Open/Close it perform the required movement of gripper only and result in disconnection with my robot connected via RoboDK (Reference 2.PNG) Ready state changed to Disconnect. 

I also tried, RunInstruction('rq_move_and_wait(0), INSTRUCTION_CALL_PROGRAM), but no result. 

It's been a while, I am unable to resolve this issue. 
Please guide me to control Gripper using RoboDK Python API.

Any help will be much appreciated. 

Attached Files Thumbnail(s)
Can anyone help on this?

(04-12-2023, 08:48 AM)mustafa Wrote: Can anyone help on this?


I have had the exact same problem for over a year

Have you heard from the RoboDK support team by any chance?

Robotiq grippers and UR robots are NOT, however, the most unusual devices...

Users browsing this thread:
1 Guest(s)