Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robotiq Gripper 2F - 85 control using RoboDK
#1
Hello Guys,

I tried the steps that are mentioned in the forums for controlling the gripper. I have used the steps as suggested by Albert (RoboDK Moderator). When I tried to run the program it displayed "No connection could be made because the target machine is actively refusing it"

I have also attached an image of the message and other details. Please let me know if I can do something to successfully control the gripper.

P.S: I have connected the UR 5 cobot with RoboDK and I'm not able to control the Robotiq Gripper 2F - 85 type.

           

Thanks in advance.
#2
Hello Guys,

Can someone help me with this process. I'm having a tough time understanding the documentation regarding this process. 

Any help with this would be really appreciated. Thanks!!
#3
Does it work if you run a normal program that doesn't require moving the RobotiQ gripper?

Can you provide a picture of the log window on your UR robot teach pendant?
#4
(10-07-2021, 03:23 PM)Albert Wrote: Does it work if you run a normal program that doesn't require moving the RobotiQ gripper?

Can you provide a picture of the log window on your UR robot teach pendant?

Thanks a lot for your reply. 

Yes, I am able to move the cobot manipulator arm by simulating the cobot but I'm not able to control the Robotiq gripper.

So when I try to run the program on the robot the manipulator arm moves around the same way it does in the RoboDK Software but nothing happens with the gripper.

Yeah sure, right now I'm not in my lab if you can provide me with some time I will post it as soon as possible.

Once again thanks a lot for replying. Much appreciated!!
#5
(10-07-2021, 03:23 PM)Albert Wrote: Does it work if you run a normal program that doesn't require moving the RobotiQ gripper?

Can you provide a picture of the log window on your UR robot teach pendant?

@Albert, here is the picture of the log window in my UR5 teach pendant. Please let me know if you need any additional information.

       


Attached Files
.pdf   Screen Shot 2021-10-07 at 4.32.23 PM.pdf (Size: 356.55 KB / Downloads: 25)
.pdf   Screen Shot 2021-10-07 at 4.31.57 PM.pdf (Size: 389.87 KB / Downloads: 23)
#6
Did you attempt to connect to the UR robot from RoboDK before taking the left picture? The log in the UR teach pendant does not show any messages (normal or error message). Once you try to connect from RoboDK you should see some messages in the log. It will probably show the error messages.
#7
(10-08-2021, 10:13 AM)Albert Wrote: Did you attempt to connect to the UR robot from RoboDK before taking the left picture? The log in the UR teach pendant does not show any messages (normal or error message). Once you try to connect from RoboDK you should see some messages in the log. It will probably show the error messages.

Hello Albert, Sorry I missed that part. I have attached the image with log information. Please let me know if this works. Thanks.

   

Regards,
Midhun
#8
(10-08-2021, 05:03 PM)Midhun Ram Wrote:
(10-08-2021, 10:13 AM)Albert Wrote: Did you attempt to connect to the UR robot from RoboDK before taking the left picture? The log in the UR teach pendant does not show any messages (normal or error message). Once you try to connect from RoboDK you should see some messages in the log. It will probably show the error messages.

Hello Albert, Sorry I missed that part. I have attached the image with log information. Please let me know if this works. Thanks.



Regards,
Midhun
Hello @Albert

Please let me know if the Image I shared was helpful in figuring the issue with controlling the gripper. Please let me know. 

Thanks,
Midhun Ram
#9
The print screen of the log window looks good. It does not show any problems. It means the robot is trying to connect to the computer. Did you try moving the gripper before taking the screenshot?

We wrote this procedure attached to connect to RobotiQ grippers. Let me know if it helps.


Attached Files
.pdf   RoboDK-UR Doc RobotiQ.pdf (Size: 152.03 KB / Downloads: 7)
#10
(Yesterday, 08:45 AM)Albert Wrote: The print screen of the log window looks good. It does not show any problems. It means the robot is trying to connect to the computer. Did you try moving the gripper before taking the screenshot?

We wrote this procedure attached to connect to RobotiQ grippers. Let me know if it helps.

Hello @Albert,

Yes, I took the picture of the log after moving the gripper.

I followed the procedure as mentioned in the PDF. I extracted the file in the correct directory and followed all the steps, but still it didn't work. The manipulator arm moves fine but the gripper control has no effect on the real cobot.

Also, when I try Send program to Robot method nothing works even the manipulator arm doesn't work it only works by selecting "Run on Robot" directly. I have attached multiple photo and log data below for your reference. Please let me know if I can try anything else. Thank you.

       
.txt   RoboDK log.txt (Size: 17.21 KB / Downloads: 0)
       
  




Users browsing this thread:
1 Guest(s)