Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Staubli TX90L CS8C With RoboDK


I have Staubli TX90L running on CS8C controller, 
The test applications that came with the controller run just fine, I work in Rhino/RhinoCAM and tried to do a simple engraving test on the machine but the controller does not seem to like the code I'm uploading to it.

I am using the VAL3 Machining post processor, even tried all the other Staubli post processors inside the RoboDK and every time it gives me an error that says application not found.

The only difference I have between the simulation and real life is that the Actual robot does not have a spindle on it yet, but in the simulation, I am simulating with a spindle

I am attaching a code I generated and pictures of the settings for reference,

Thank you!

Attached Files Thumbnail(s)

.zip (Size: 29.71 KB / Downloads: 37)
I believe that the Staubli VAL3 Machining post processor requires the HSM Software package from Staubli. You can find more information here:

On the other hand, you should be able to customize your own integration to drive your spindle. What issues did you find with the other post processor? The default post processor Staubli VAL3 should work for Staubli CS8 controllers.

Can you provide the RDK project file? We may be able to help you better.
Hi Albert,

Thank you for looking into this for me!
Please see the attached station file.

Spindle integration will be manual, I can easily wire VDF and control the spindle on and off and even RPM manually.

I used every single post processor for Staubli and they all gave me the same error and the robot does not even budge.

Attached Files
.rdk   TEST STATION TX90L.rdk (Size: 1.12 MB / Downloads: 43)
Hi Albert,

Discussing this issue with Staubli technical support as well and through the log file we found that the application I get from RoboDK is compatible with SRC version s7.5.3 and higher, but my controller runs on SRC verion s5.4.1

What do you think a solution could be, besides upgrading the controller to the s7.5?

Thank you!
In this case I would try with the Staubli S6 post processor which is the one that supports older Staubli robot controllers. It may require minor changes to make it work with the controller version 5. Also, you can try removing all program calls from your setup (such as the change tool and set spindle speed) to have a proof of concept, as shown in the attached project.

If you generate the program now you should obtain a small program you can use as a simple proof of concept. You can try integrating the spindle RPM later.

Attached Files
.rdk   TEST STATION TX90L-v2.rdk (Size: 1.12 MB / Downloads: 46)
Hello Albert,

Thank you for your input.
I tried posting and running the application from the file you attached to your reply but same issue it does not like it.

I have been going through a back and forth with Staubli to update the controller software to S6 or S7 and over a week already they are not being responsive at all.

I want to look into asking RoboDK to make me or downgrade the post to the S5 version that my controller runs to be able to make this robot functional. 

let me know if this is an option at all, and what the next steps would be even if its the conversation that needs to move into emails as opposed to the forum

thank you and looking forward to making this work!
Do you have a Professional license? We would usually charge to develop such post processors but we can better take a look and provide you wtih a quick edit if they are minor edits to make the Staubli S6 post processor work for your controller.

Can you provide us with a sample program generated by your controller or a program that you know it works with your controller?
Hello Albert,

Please see the attached file, there are two applications in there that I tested both of them ran without problems, they came with the robot when I purchased it.

Right now I don't have any licenses, still rolling with the trial version, very soon I'll be purchasing an educational license, as soon as the College gives me everything that I need to verify the status with RoboDK.

Please have a look at the attached files and let me know what the next steps will be even if it is some charge for development.

Thank you Albert!

Attached Files
.zip   Samples for (Size: 7.91 KB / Downloads: 27)
The Staubli programs you shared look similar to the output you get by generating programs using the Staubli S6 post processor. Did you try generating a program using the Staubli S6 post processor? What error messages do you see?
Hi Albert,

I agree, they look very similar, the point coordinates are the only visible difference for me, I use WinMerge to compare the codes. The pendant sees the application folder and I'm sure there are application files in the folder, but it says application not found. I'm using file zilla to upload the application/code and flash drive as well but result is the same error

Please see the pictures and the application below
Thank you!

.rdk   TEST ENGRAVE STATION TX90L CS8C.rdk (Size: 879.23 KB / Downloads: 34)

Attached Files Thumbnail(s)

.zip   Engrave (Size: 2.81 KB / Downloads: 25)

Users browsing this thread:
1 Guest(s)