Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Connect to UR5

Are you still under your 30 days trial?
No, 30 days trial period is over

I have tried with freshly installed RoboDK, but the result is the same. I got stuck on waiting, maybe the licence is not the case. Do we have alternative way to get the joint positions and set the joint position of the robot using RoboDK? For example like the UR_Activate monitoring macro? When I run this macro I can get the joint positions, but with delay, and the delay is not constant, some random delay and it gets bigger with time? Could you provide any example code? I would appreciate any help, I wanted to use the RoboDK in my thesis work.

Best Regards,

Dear all,

As I have noticed in the UR_ActivateMonitoring macro we use the port 30003 and I can read the joint positions with delay, but dont have connection still (stuck on waiting). If I change the robot port to 30002 I can not read the joint positions anymore. So the port could be the problem? Because in the log file it says that the default robot port is 30002.

Available local IP addresses (IPv4):
Server stablished at:
Warning: Using older controller compatibility (IO not supported)
Connected to Sending program :/progrobodk_basic.script...
Updating computer IP on program:
Updating computer port on program: 30003
Program sent.

Is there way to change the default port?

best Regards,

The port you can specify in RoboDK is the port used by the computer for the robot driver:
The robot will connect to this port on your PC so that you can drive the robot from RoboDK.

However, when you start the driver process to connect to a UR robot you'll see a brief communication through the port 30002 of the robot (Universal Robot's Dashboard server). This TCP/IP communication happens because RoboDK's driver program is transferred and triggered to establish the communication between the UR robot and RoboDK.
what could be the possible problem for not connecting? I have followed all the steps in this thread.
Did you do the test with another computer like I asked you?

Reading your answers, I don't feel like you tried.

Yes, I have tried with other computer, I have tried to connect using the switch, I have tried to connect directly(ethernet connectrion between PC and UR5). May be it is the Polyscopre version, but I dont have permission to update the robot because my department is teaching with this version.

Best Regards,
Hi mnurpeiissov,

I'm sorry to hear that you are not able to connect to your UR controller.
I hope that you understand that we cannot help you more than we already did from a distance, especially if you can't update the Polyscope version of your controller.

Many of our users connect with UR controllers on a daily basis.

Have a good day.
Hi Jeremy,

Thank you for your help, I really appreciate it. One last thing, why there is delay in the UR_ActivateMonitoring macro? Could this be because of GIL, because the threading is used to get the data from UR. Could you think of other way of implementing it? Is there a way to control the UR5 using TCP connection if I stick to this method of getting data (USING THIS MACRO and CONTROL IT SIMILAR TO THIS MACRO)?

Best Regards,

Mukhamet Nurpeiissov

Users browsing this thread:
2 Guest(s)