Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Kuka - RoboDK Integration

Hi All :), 

Trying to connect a Kuka agilus KR6 r900 2 robot (with KRC4) with roboDK

I have followed all steps defined in this manual - Link

Achieved communication with the robot and have successfully retrieved it's position

Currently stuck trying to run a program from roboDK on the robot.

Referring to this line (last line in the manual) "Manually start the “RoboDKsynch.src” program to make the robot behave like a server that responds to move commands coming from the PC."

I've tried to manually start the program from the teach-pendant or directly from the controller (via screen & keyboard..) I'm constantly receiving error "KSS01324 .src not available"

Tried changing to automatic & external operating modes and also restarting the controller.

Would appreciate any suggestions !

Thanks :)
Hi Guy,

It is the first time I see this error. Something may be wrong with the configuration of the controller.

Are you able to run any other programs?
Did you purchase the robot directly from KUKA?

Hi Albert,
Yes - Robot was purchased directly from Kuka
Yes - Able to run other programs exported from roboDK with kuka_KRC4 post processor, experimented with several (with some caveats that could be related to the simulation programed)
Is there any tale telling files I can attach that will shed light over this ?
Hi Guy,
Did you declare the global variables as described in the procedure? 
(the $CONFIG.DAT file)
Can you provide more information or a screenshot about the error?

I am having a similar problem with “RoboDKsynch.src” program.
How did you solve it?

had other questions too, so i started a new thread instead of latching onto someone else's
Same error.. how do I get around it?
Maybe there is a way out.  Manually Changing the name of def function  to be exactlly same as the SRC file name. Of course ,you should define certain global variables in $ config.dat first.

Attached Files Thumbnail(s)
Thank you for your feedback Peter! We'll fix the official version of our driver script.

Users browsing this thread:
1 Guest(s)